Latency and mouse delay problem [2018]

This section is for discussing technical questions relating to the Beta version of Survarium, including game-bugs.

23.01.2018, 12:51

I have started playing Survarium 2 years ago and back then I understand that game was in early development and there are bugs and glitches, but NOW, in 2018, there is STILL latency/delay thing that is just making game unplayable! Lowest latency is around 80 and max. around 400...I am located in EU and this happens in EU servers too, not to mention RU ones.

Enemies coming around corner see me first than I see them and guess how that ends.

Mouse movement is terrible. When I swipe I feel like there is a bit of delay and its just making gunfights impossible.

OK guys, you implemented "PvE" mode, could you please focus more on playability of your game? Or is there something now that could fix this or at least minimize its effects?
User avatar
juicehans
 
Posts: 2
Joined: 06.01.2015, 16:13

23.10.2019, 15:24

why do i always have 250-380 as latency on eu servers ????

Andante2
 
Posts: 1
Joined: 16.07.2017, 15:30

23.10.2019, 18:01

Andante2 wrote:why do i always have 250-380 as latency on eu servers ????

Maybe give more details? Where do you live? What's your connection? Are you on cable, fiber or wifi?
User avatar
Chandrian
Supermoderator
Survivor
 
Posts: 3302
Joined: 03.04.2013, 18:33
Location: Spain

24.10.2019, 07:57

Check if you have hardware acceleration ticked in mouse settings in Windows.
User avatar
Tanatloc
 
Posts: 924
Joined: 08.03.2016, 17:01

11.11.2019, 11:59

Same thing with mouse. It's something weird when you move mouse, like some acceleration and little bit of delay.
User avatar
M4rk0
 
Posts: 157
Joined: 08.10.2016, 16:07
Location: ILS

In order to reply you must be signed in.

Return to Technical